Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

mikec35

Samsung top loader VRT - loud pop then no power

Recommended Posts

mikec35

I have a Samsung VRT, it was one of the ones that was recalled for the vibration/lid issue.  I just started a cycle and water just started to pour into the machine then I heard a loud pop and then there was no power.  I could smell something burning.  I took the control panel apart and saw a charred board on the backside of the power switch.  I am unsure of the model #, it's not easily found on this machine, at least not where I have it located, I think I need to pull it out and turn it around.  My questions are, is there any repair available for the control panel?  If not is it worth it to purchase a new one, and if so where can I get one?  Please see pics and advise.  Thank you, Mike

 

IMG-4595.png

7xc-G0-D5-QB6-Qbez-Vsn-V5-TQ.jpg

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

16345Ed

Need to buy new control board. Need model number to do so. 

Share this post


Link to post
Share on other sites
MichTech517

Agree with 16345Ed, You need to find the model number on the unit and look up the control board. Then once you can get a price on the control board you can figure out if it’s worth replacing it or buying a new washer. You may be able to find a used one for cheap on eBay or something if you want to go that route. 

Share this post


Link to post
Share on other sites
mikec35

Thank you.  I found some control boards on eBay, I'll try one out since they are not that expensive.  Hopefully nothing else is wrong that may have contributed to the original one blowing.

Share this post


Link to post
Share on other sites
mikec35

I ordered a board, I'll report back if it works.  It's crazy how many people mix up the control board and user interface board on eBay - wrong picture with the correct part #... Hopefully I got it right.  Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.