Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

DISCLOSURE: We may earn a commission when you use one of our coupons/links to make a purchase.

Amana gas range model AGR5835QDS, S/N 14422143ER: Oven temp not controlling properly


Recommended Posts

I have an Amana gas range model number AGR5835QDS, S/N 14422143ER that has issues controlling temperature in the oven. My noticed some time ago that the oven seemed to running far hotter than it was set for , and the way stuff cooked seemed to confirm that. Because I can't help myself, I logged the temp in the oven with a thermocouple, and that confirmed her suspicions. A shot of the graph is attached. The oven was set for 325F, note that the temp peaked around 525F and then bobbled around averaging maybe 475 or so. The small dip at 17:57 is when my wife opened the oven to put the tater tots in.

It behaves this way pretty much whatever you set the temp at. The burner cycles, it just does so at way too high a temp, always around 475F average. Over time we have sort of adapted our cooking to this, but I'd like to sort this out.

What I have done thus far:
- Tested the sensor, the room temperature resistance is as expected and it changes with temperature.  
- I replaced the sensor anyhow, behavior is exactly the same.
- Some research found that there is a menu option in the controller to put and offset correction into the controller. I put in as large an offset that it allows (+/- 30F if I recall correctly), this also did not change anything.
- I have searched online for any method to re-calibrate the control, but beside the aforementioned temp offset, have found nothing.  There are no obvious (to me anyhow) adjustment on the control board that I can see.

- Studied the schematic, but beyond the sensor and the gas valve*, pretty much everything is contained on the control board, and I do not seem to be able to find schematics for that.

- Done a close examination under good lighting and a magnification of the control board for poor solder joints, obvious burned or overheated components, etc., and found nothing suspicious.

Replacing the control board is a significant enough portion of the cost of a new range as to almost not be worth considering.
Is this a common failure?
Before I just either replace the range or take some other drastic measure, any ideas, suggestions, or guidance?

Thanks very much for any ideas.

*Semi related question on the function of the gas valve and igniter: Looking at the schematics, I see that the igniter is wired to be in series with the valve. Does the igniter simply stay lit any time the burner is on?

oven temp crop.jpg

Link to post
Share on other sites
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

  • clavius

    2

  • Quick

    1

Popular Days

Top Posters In This Topic

Popular Posts

Did you unplug the sensor connector at the board and take a resistance reading there? You should be able to follow the wires from the sensor to the board to determine what connector belongs to the sen

Posted Images

2 hours ago, clavius said:

Does the igniter simply stay lit any time the burner is on?

 

Did you unplug the sensor connector at the board and take a resistance reading there? You should be able to follow the wires from the sensor to the board to determine what connector belongs to the sensor at the board. Perhaps a bad connection down at the sensor or maybe even the board? Damaged wires (harness) from the sensor to the board? If all that checks good and I have not looked at a schematic but from what your implying yea bad board if you replaced the sensor and the connections and wiring harness check good. It would have to be a bad board by the simple process of elimination. 

Yes the ignitor is on the entire time the flame is burning and calling for heat.

  • Like 1
Link to post
Share on other sites

Thank you for taking the time to reply.

It's been a while now since I last dug into this, so I am not sure if I did the test you mention of checking the resistance at the control board end. Excellent suggestion, I will make a point of checking that. I am figuring on pulling the range out again and giving all of this another close look. It is the logical process of elimination conclusion as you note. I fix stuff for a living, but not appliances, so I figured I may as well ask among people who work with this stuff a lot more than I do.

If I end up replacing the range, I want to at least make sure I'm out of options for a repair. A quick search seems to say that the control is no longer available from the manufacturer, though there are lots of used ones on the auctions sites, etc. Not sure I care to go that route.

Thanks again for your input and for confirming how the igniter works. I appreciate your help. I will report what I find and where I end up when I get back to working on this.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.