Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Dumbstruck by the new computer-controlled appliances? Let the Samurai enlighten you…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
crosstalk

Kenmore dehumidifier 580.51450100

1 post in this topic

Hello. I am trying to figure out why the subject dehumidifier isn't working correctly. It seems to run for a few minutes (fan, compressor, and produces some water) then stops (fan and compressor as far as I can tell). Sometimes adjusting the settings on the electronic control panel starts it running for another few minutes but it should be running much more considering the humidity is high in the room and I am setting it on 30%.

Of course replacing these things isn't too expensive but I am wondering where to start on troubleshooting this one. Maybe the humidity sensor or electronic control can be bypassed?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!