Lost with the new appliances? The Samurai teaches you Circuit Fu…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Guest

Whirlpool Water Heater FG1F3030T3NOV

5 posts in this topic

reputation_pos.gif Hi

The pilot light wont stay lit on my Whirlpool (yeah Whirlpool sucks I know) gas water heater. I have had to replace the TC (thermocouple) before, so I went to Lowe's to get a new one. Unfortunately they told me that Whirlpool has discontinued making the TC for my unit (which was left hand thread) but now has a conversion kit which is free, and uses an adapter to make it right hand thread, and uses a thermal switch.

I replaced the old parts and installed the new which consisted of a new TC and pilot line and gas line. The pilot would still not stay on so I called Whirlpool who had me check the reset on the thermal switch and bypass the wires to the TC, still no go. They then said it was most likely the gas control valve. So I ordered a new one of those which wasn't free and installed it.

This still didn't work I can't get my pilot light to stay lit. I have checked the amp draw on the TC which is supposed to be 12MA but seems to give me 3.4? maybe I am not checking it right...(I have 3 TC's all brand new and none of them work)

I have checked the flow to the pilot light, that seems to be good I have a nice bright blue flame. The flame seems to be making good contact with the thermocouple.

So as of right now I have:

1. A new TC

2. A new gas control valve

3. Everything new...except the burner.

What am I doing wrong or missing that is not letting me get this water heater to work?..HELP!

P.S. will the burner having a small crack in it cause the pilot to not stay lit?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

[user=64102]Lo_skillz[/user] wrote:

... the TC which is supposed to be 12MA but seems to give me 3.4? maybe I am not checking it right ...

I'm not sure .. but is it far enough into the Flame ?

Whirlpool Water Heater FG1F3030T3NOV made by AMERICAN WATERHEATERS

FG1F3030T3NOV Parts List & Diagrams at SearsPartsDirect

Share this post


Link to post
Share on other sites

It looks close enough but I can't really see into there very well..is the flame adjustable or would I have to bend the bracket? I have it seated all the way down into the hole.

This is really frustrating me...everything is new and it doesn't work.

Share this post


Link to post
Share on other sites

I don't know how that system works..

maybe someone else on here may eventually log-on and answer ..

 

 

Share this post


Link to post
Share on other sites

WOOT! I got it working! Yeah I had to bend the bracket to where the TC and the pilot tube were almost touching and readjust the igniter a little and it fired right up...POS.

Thanks for the suggestion.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now