Dumbstruck by the new computer-controlled appliances? Let the Samurai enlighten you…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
chrisny

Lennox G26Q3-75-5 with both LEDs off; no heat

4 posts in this topic

Our Lennox gas furnace was serviced less than 1 week ago, and in addition to 20-pt. annual maintenance they installed a whole house humidifier unit. Furnace worked fine for about 5 days, then all of a sudden no heat yesterday. Before looking more closely at the furnace I thought it might be a new thermostat that was needed, so I installed a new 3M Filtrete touchpad unit upstairs in the kitchen. Nice thermostat, but STILL NO HEAT. So I go down to take a closer look at furnace, and I see both diagnostic LEDs are OFF, and there is no sign of any current whatsoever reaching the furnace. Furnace switch is on; circuit breaker on home service panel is ON. I even pressed the internal circuit breaker on the furnace control box a few times. Still no heat, no flame, and no sign of current reaching the furnace control box. Could it be that I need to replace the CB8 circuit breaker, or is something else going on? PLEASE HELP!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

P.S. -- I realize the installation of th humidifier is probably an irrelevant factoid, but I feel kind of suspicious that the serviceman screwed something up while doing the annual maintenance, like loosening a wire perhaps -- thhough everything SEEMs to be in place. Thanks a million for any ideas!

Share this post


Link to post
Share on other sites

Is the Access Door closed on the Furnace ?

The Circuit Breaker CB8 is re-settable.

Inside the Control Box:

(with Door Switch closed)

there should be 24v AC between C and R

there should be 120v AC between Terminals L1 and N

Share this post


Link to post
Share on other sites

Thanks for the quick followup, GMF. The access door is of course closed when I am testing to see if the thing works. I have actually reset the CB several times, to no avail. The CB reset button seems somewhat loose and flimsy; don't know if it was always that way.

Unfortunately I have no way of testing voltages. Hopefully I'll have a guy coming over tomorrow or after -- so, we'll see, I guess. Thanks anyway, though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now