Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

DISCLOSURE: We may earn a commission when you use one of our coupons/links to make a purchase.

Fridge not cooling/freezing enough


iirmischer

Recommended Posts

Hi, My refrigerator has gradually stopped cooling properly. Currently, it cools the freezer to about 20 degrees Fahrenheit and the fridge to about 48 degrees fahrenheit. I have it on settings to cool to -o F and 32F. I had a tech come out and he said he couldn't fix it. it was a system problem. I have some pictures I attach.  the middle picture is the fridge and I think the evap. It was frozen. I thawed everything out and took some more pictures with the evap cover off. The drain tray was broken - probably from the frozen ice. It had some green and brown color on it. that is also in pictures. When I thawed the ice on the evap I didn't get water everywhere so I think it drained properly.

 

Any recommendations on what to do next?

 

1472995726_modelandfrozenevap.thumb.JPG.77171d9492ff600bb05acc73f971bc0a.JPGtwoMore.thumb.JPG.d0c14972b7950f196677073c73273661.JPG1818091519_trayandevap.thumb.JPG.42545dac6efde2c63637f59eacbc9cb4.JPG

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

  • MichTech517

    1

  • everardo gonzalez

    1

  • iirmischer

    2

  • max999

    2

I had the same problem with my Samsung Refrigerator and the problem was the damper did not open to let the cool air flow to the food compartment. Check your damper could be the same problem.

 

Link to comment
Share on other sites

Hi, I have  dual evap kitchenaid fridge(KFIS29PBMS01 with freezer that is warm then normal @15F instead of 0F . The fridge is working just fine, its always between 34-38F. I did measure both thermistors RC/FC once disconnected from P5 I get
7.2K/13.5K the actual temp is 37/18F at the time I measured, I then compared it to the W10316760 Thermistor chart and for
37/18F it should be 7.7K/13.4K , the fridge temp is off but the freezer thermistor is in range. I than ran all the
thermistor via the service DIAG. and it returned a value of "01" = pass for both. RC/FC Evaps fans are fine too, I can hear them running when they are turned on via service DIAG.
when FC is in defrost the temp shoot up to 28F , it hot here today(84F), I will get a pic of the FC evap coil when is has
frost on it, I think it is normal. but I might be wrong. it maybe the 3 way valve ,right? 

thanks a million, 
 

Link to comment
Share on other sites

On 9/10/2021 at 8:43 PM, everardo gonzalez said:

 

 

Do you hear the fan in the freezer running when the compressor is running? Also, have you clean the condenser coils and is the condenser fan running when the compressor is running? 

Link to comment
Share on other sites

when the compressor is running and I open the freezer door i see that the fan is running and I see light frost on the coils. yes I cleaned the condenser coils. yes, the condenser fan when compressor is running. 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.