Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

Steverator

Whirlpool immediately fried new relay - ED2FTGXKT00

Recommended Posts

Steverator

Fridge stopped cooling, found PTC relay was broken/fried (possible due to power outtage/blip), I was able to jump R to S (for a sec) to get comp running while waiting for new relay (61005518).

Installed new relay, comp started, but then immediately started cooking the new relay again! Removed newly fried relay, manual jump start still works and comp seems to run just fine this way.

Did I install the wrong relay? Is there something else that would cause this?

Thanks very much for your help!

Share this post


Link to post
Share on other sites
ming

Measure the start and run current when you jump start the compressor, then compare with the start and run current when the relay is plug  

in the compressor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.