Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

Search the Community

Showing results for tags 'defrost prob'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Appliantology Welcome Center
    • Kendo Masters Hall of Fame
    • Site Orientation
    • Announcements
  • DIYer Appliance Repair Forums
    • DIY Appliance Repair Help
    • Find a Local Tech
    • Appliance Haikus
  • Appliance Service Manual Requests
    • Appliance Service Manual Requests Forum
  • Professional Appliance Technician Forums
    • Appliance Repair Tech Forum
    • Professional Appliantologist Webinars Forum
    • Samurai's Appliance Repair Video Classroom
    • Samurai’s Appliance Puzzles
    • The Dojo

Blogs

  • Samurai Appliance Repair Man's Blog
  • kdog's Blog
  • Mrs. Samurai's Kitchen
  • DurhamAppliance's Blog
  • applianceman97's Blog
  • LI-NY Tech's Blog
  • tpoindexter's Blog
  • Smashycomman's Blog
  • acfixerdude's Blog
  • Tech notes
  • Eugene's blog about stores, fixing, life, and more!
  • Moostafa's Hookah Tent
  • Son of Samurai's Blog
  • Quick's Blog
  • Beyonddoubt's Blog

Categories

  • Appliance Repair Manual Stash Access File®
  • Appliance Repair Manual Pot Luck Supper

Calendars

  • Tech Training
  • Birthdays

Product Groups

  • Memberships

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. ******Message to the moderator: Please could you delete my other thread about the same subject ( title Defrost problem Inglis WPW10292244 refrigerator, posted june 21) . I'm unable to correct the title with the right model number***** My Inglis refrigerator still have a defrost problem. Here's what I've done lately. Today I had to defrost manually with a air dryer the evaporator. But before doing the defrost thing , I tested with the maintenance menu the thermostat circuit. The JAZZ board still returned me an O (open) circuit. I then probed it with an ohmmeter disconnected from the circuit and still frozen. The thermostat read was ok. It read 0 ohm. So its closed. I reconnected the thermostat to the circuit. I probed the resistance of the heating element ( disconnected from the circuit) It read 33 ohm. So its not burn open or shorted if the resistance value is ok. So everything in this area looks fine. I tested the voltage at the two disconected terminals of the heating element and I mesured nothing. So I started a manual defrost in the maintenance menu of the Jazz board. I took again a voltage reading. Around 15v was present at the terminal. So I plugged the terminals back....nothing seem to happen. So I back probed the terminal and it read 0v. I disconnected the terminals, still in forced defrost mode, and now I read 14v. I reconnected the terminal and nothing 0v. So everything seem to point in the direction of a defective JAZZ board. What you guys think?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.