Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

Search the Community

Showing results for tags 'burn'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Appliantology Welcome Center
    • Kendo Masters Hall of Fame
    • Site Orientation
    • Announcements
  • DIYer Appliance Repair Forums
    • DIY Appliance Repair Help
    • Find a Local Tech
    • Appliance Haikus
  • Appliance Service Manual Requests
    • Appliance Service Manual Requests Forum
  • Professional Appliance Technician Forums
    • Appliance Repair Tech Forum
    • Professional Appliantologist Webinars Forum
    • Samurai's Appliance Repair Video Classroom
    • Samurai’s Appliance Puzzles
    • The Dojo

Blogs

  • Samurai Appliance Repair Man's Blog
  • kdog's Blog
  • Mrs. Samurai's Kitchen
  • DurhamAppliance's Blog
  • applianceman97's Blog
  • LI-NY Tech's Blog
  • tpoindexter's Blog
  • Smashycomman's Blog
  • acfixerdude's Blog
  • Tech notes
  • Eugene's blog about stores, fixing, life, and more!
  • Moostafa's Hookah Tent
  • Son of Samurai's Blog
  • Quick's Blog
  • Beyonddoubt's Blog

Categories

  • Appliance Repair Manual Stash Access File®
  • Appliance Repair Manual Pot Luck Supper

Calendars

  • Tech Training
  • Birthdays

Product Groups

  • Memberships

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 3 results

  1. I have a Kenmore Microwave model: 721.66339011. It has started to put out an "electrical burn" smell when running. It appears to run fine still, heats, and works correctly. I have the top off and can run it. I can't see an smoke or isolate any particular part that seems to be the source of the smell. How do I troubleshoot this? Thanks for any help. Ray
  2. Samurai Appliance Repair Man

    Trailer Home Service Calls Are The Worst

    From the album: Ovens, Ranges, Stoves

    www.ApplianceGuru.com
  3. Samurai Appliance Repair Man

    Extreme Burn Damage To A Dryer Pigtail Terminal Block

    From the album: Dryer Repair

    This is easily avoided by ensuring your power cord connections at the terminal block are goodntight! Buy your replacement power cord and terminal block here ==> http://www.repairclinic.com/Shop-For-Parts?s=t-dryer%20power%20cord-%3d%3d
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.